nDiki : 2000年12月08日

2000年12月8日 (金)

PHP 3 なら動く……

結構前から、「PHP を使ってみよう」ということで自分の環境(Debian GNU/Linux woody)に、PHP 4 のパッケージをいれてみているんだけど、動かない。 もう少し具体的にいうと、

  • インストールしているのは php4, php4-cgi とその仲間たち
  • php4 (Apache のモジュールとして動作)を、モジュールとして組み込むと Apache が正常に動かない(PHP 4 で書いたページにアクセスすると落ちる)。
  • php4-cgi (CGI 版として動かすもの)は、コマンドラインから単体ではきちんと動作するのに、Apache から CGI として呼ぶと Segmantation Falult で動かない。
  • 自分で php4 コンパイルしたのも CGI で同様の状況。

ということで、困っていた。 諦めて php3 を入れてみたらこちらは動く。 php4 はそれ自身国際化されつつあるし(php3 は別に国際化版あり)今後の事も考えると php4 にしたいところなんだけどねぇ。

ライブラリまわりの問題なのだろうか? 何度か php4 の方も、Apache の方もパッケージアップデートされている(upstream 自体もあがってる)のに駄目だから。 しばらくは php3 を使うかな。 php3 国際化版はまだパッケージにないので、自前でビルドしなくては。

スポンサード リンク
[ 12月8日全て ]

About Me

Naney Naney (なにい)です。株式会社ミクシィで SNS 事業の部長をしています。

nDiki1999年1月に始めたコンピュータ日誌を前身とする NaneyWeb 日記(兼パーソナルナレッジベース)です。ちょっとしたノートは nNote にあります。

※内容は個人的見解であり所属組織とは関係ありません。

月別インデックス
Process Time: 0.04476s / load averages: 0.47, 0.46, 0.48
nDiki by WATANABE Yoshimasa (Naney)
Powered by DiKicker