nDiki

2004年8月23日 (月)

[ Perl ] PPM::Make 0.71 の dependency パッケージ誤認

Term::ProgressBar を PREREQ_PM にしているパッケージを make_ppm すると、ppd に Term-ProgressBar ではなく Term-ProgressBar-2.06 が DEPENDENCY として出力される。

CPAN にある最新パッケージが Term-ProgressBar-2.06-r1 と、ちょっと変則的なバージョン番号がついているので誤認しているようだ。 PPM::Make::Util::version あたりでヒューリスティックにパッケージ名バージョン番号を分離しているっぽい。

とりあえず出力されたPPDを手で直すか。

[ 8月23日全て ]

About

Process Time: 0.044989s / load averages: 0.21, 0.27, 0.25