nDiki

2006年2月7日 (火)

古い Crypto++ は古い GCC

Crypto++ を使用しているかなり以前に書いた C++ プログラムを動かそうと思ってコンパイルしたら、あっさりエラー

もともと Crypto++ 4.2 用のコードなので、Debian GNU/Linux sid の libcrypto++-dev (5.2.1c2a-2) では API が変わりすぎていて駄目。

ということで Crypto++ 4.2 のソースを取ってきてビルドしようとしたら、こちらは GCC が新しすぎて駄目 (4.0.2-8)。入れてあった GCC 3.3 でも駄目 (3.4.5-2)。

結局 GCC 2.95 (2.95.4-24) を入れてコンパイルしてようやく通った。

またいつかビルドする日が来た時のためにメモ

Debian は各バージョンの GCC を共存させてインストールできるので、こういう時は大変助かる。

スポンサード リンク
[ 2月7日全て ]

About Me

Naney Naney (なにい)です。株式会社ミクシィで SNS 事業の部長をしています。

nDiki1999年1月に始めたコンピュータ日誌を前身とする NaneyWeb 日記(兼パーソナルナレッジベース)です。ちょっとしたノートは nNote にあります。

※内容は個人的見解であり所属組織とは関係ありません。

follow us in feedly

月別インデックス
Process Time: 0.1868s / load averages: 0.49, 0.66, 0.70
nDiki by WATANABE Yoshimasa (Naney, Google profile)
Powered by DiKicker