nDiki

2010年8月19日 (木)

Strawberry PerlCPAN モジュールがこけるのはセキュリティソフトのせい

Strawberry Perl を 5.10.0 系から 5.12.1 系に入れ替えたので再度 CPAN モジュールを使って必要な Perl モジュールインストールしようとしたが、前のバージョンの時と同様

 "Couldn't move...

と出てエラーで止まってしまった。今回は解決しておこうと調べたところ Norton Internet Security のせいらしい。ロック関係だとは思っていたが、NIS が掴んでいたか。一時的に Auto-Protect を無効にしたらすんなり通るようになった。

@bulkneets 氏からの言及経由 @mikio1978 氏によると FILE_SHARE_DELETEとかの共有フラグを立てないでオープンしてしまっているからのようだ。

スポンサード リンク
[ 8月19日全て ]

About Me

Naney Naney (なにい)です。株式会社ミクシィで SNS 事業の部長をしています。

nDiki1999年1月に始めたコンピュータ日誌を前身とする NaneyWeb 日記(兼パーソナルナレッジベース)です。ちょっとしたノートは nNote にあります。

※内容は個人的見解であり所属組織とは関係ありません。

月別インデックス
Process Time: 0.149133s / load averages: 3.08, 1.21, 0.97
nDiki by WATANABE Yoshimasa (Naney)
Powered by DiKicker